Cómo hacer un backup de Mikrotik

Es muy importante contar con un archivo de respaldo (o backup) en caso de que el equipo se dañe o pierda alguna configuración. A continuación encontrará las instrucciones para crear un backup de su router mikrotik y recibirlo en su e-mail.

El proceso consta de 2 pasos principales, primero desde la configuración de su cuenta Gmail, y luego a través de Winbox accediendo a su router mikrotik.

También puede interesarle Cómo proteger nuestro Mikrotik

1. Habilitar Gmail para enviar correos desde aplicaciones de terceros

Lo primero que debemos hacer es habilitar la autenticación de dos pasos de nuestro correo Gmail. Diríjase al ícono con su inicial/foto de su cuenta y cliquee en “Gestionar tu cuenta de Google”.

Luego cliquee Seguridad > Verificación de dos pasos.

En el campo de teléfono coloque un número de celular válido, para que Google envíe un SMS y compruebe la cuenta. Luego ingrese el código recibido con formato similar a “G-12345”.

De esta manera la Verificación en dos pasos figurará “Activada”. Ahora deberá configurar una clave para usar en su Mikrotik desde Seguridad > Contraseña de aplicaciones.

Elija Correo y Seleccionar dispositivo > Otro.

Después escriba un Nombre (por ejemplo “MIKROTIK”), y cliquee “GENERAR”.

Luego de esto aparecerá en pantalla una clave de 16 caracteres, que es la que usará en su Mikrotik para enviar el backup por e-mail.

2. Configurar Mikrotik para enviar e-mails a través de Gmail

Ingrese a su Mikrotik a través de Winbox Tools > Email y configure los parámetros:

  • Server: 142.251.0.109
  • Port: 587
  • Start TLS: yes
  • From: tumail@gmail.com
  • User: tumail@gmail.com
  • Password: la password de 16 caracteres que obtuvo en el paso anterior.

Para encontrar su server SMTP de Gmail más cercano, realice ping smtp.gmail.com y use la IP que aparezca.

SI todo es correcto deberá poder enviar el e-mail desde el botón “Send Email”.

Lo siguiente es crear la tarea programada con nuestro script de backup desde System > Scheduler:

  • Name: Backup
  • Start Date: Jun/07/2022 (revise que la hora de su mikrotik sea correcta)
  • Start Time: 01:30:00 (hora a la que se correrá el backup)
  • Interval: 1d 00:00:00 (cada cuánto se correrá el backup, en este caso es cada un día)

El resto de las opciones no se modifican.

Pegue el siguiente script en el cuadro blanco, reemplazando “tumail@gmail.com” por el e-mail que configuró en el paso 1.

log info "Iniciando respaldo"
:global backupfile ([/system identity get name]. ".rsc")
/export file=$backupfile
:log info "Creando el respaldo..."
:delay 10s
:log info "El respaldo esta siendo enviado a su correo"
/tool e-mail send to="tumail@gmail.com" subject=([/system identity get name] . \
" Backup") from=tumail@gmail.com.com file=$backupfile
:log info "Envio de respaldo finalizado"
:delay 60
/file remove ([/system identity get name].".rsc")

Finalmente recibirá un e-mail con el archivo del backup, formato .rsc

Más información Mikrotik en video

MikroTik: Vinculaciones – Configuración inicial Wispro MikroTik – Reglas de Wispro MikroTik – Aprovisionamiento de IP – Cambio de equipo – Resincronización de datos.
¿TIENE OLT? CÓMO REALIZAR UN BACKUP DE OLT
Si necesita ayuda con esta guía por favor contáctese con nuestro soporte online
o solicite un turno en el calendario.

Wispro

Deja un comentario

Tu dirección de correo electrónico no será publicada.